黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统

前言

LEDE是一种开源的路由器系统,可以根据自己需求进行定制。这里我们安装的是KoolShare论坛定制的LEDE系统,已经集成了大量硬件驱动及常用插件,可以省去很多功夫。利用群晖的虚拟机套件(Virtual Machine Manager),我们可以轻松的在黑群晖上实现一机多用,既是一台NAS,又是一台软路由。

这里首先需要你的黑群有两个网口,一个做WAN,连接光猫。一个做LAN,用于其他设备的连接。我这里是利用了一张千兆PCIE网卡扩展了一个接口。

本文所使用的所有资源会分享在文章下方。

操作步骤

一、虚拟机的创建

首先打开虚拟机套件(Virtual Machine Manager),选择“映像”,点击“新增”。

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

名称根据自己的需要填写,选择“从PC上传文件”,选择LEDE软路由的img镜像后点击“下一步”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

下一步选择系统映像的存储空间,根据需要自行选择,选择完成后点击“应用”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

稍等片刻,映像创建完毕

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

转到“网络”,点击“新增”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

创建虚拟交换机,点击“下一步”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

这里用目前连接光猫的口作为WAN口,其他默认,点击“应用”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

按照同样的步骤,再创建一个LAN口,这里用另外一个网口创建。

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

这样就创建好了。(这里由于网口2我还没有连接设备,所以显示为错误)

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

找到“虚拟机”,点击“新增”右边的小倒三角,选择“导入”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

选择从硬盘镜像导入,选择我们刚才创建的映像,点击“下一步”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

选择存储空间,点击“下一步”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

规格这里就根据自己的需要配置,点击“下一步”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

这里默认即可,点击“下一步”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

这里添加两个网口,一个WAN,一个LAN,型号都选择e1000,MAC地址随机生成即可。

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

其他设置默认即可。

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

查看一下我们的配置,确定无误后勾选“创建后开启虚拟机”,点击“应用”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

这样我们就完成了LEDE软路由虚拟机的创建。

二、修改一下LEDE软路由系统的配置

点击“连接”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

会在新窗口打开虚拟机窗口,这样其实LEDE系统已经启动完毕了,我们点一下回车即可

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

我们编辑一下网络配置,输入如下命令:

vi /etc/config/network

按 i 键进行编辑

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

由于每个人的情况不同,请根据自己网络的实际情况进行配置。

以下是有关代码的说明:

LAN口配置下有一段:

option type 'bridge' (这一句删除:网络类型桥接模式)

config interface 'lan' LAN口配置
    option ifname 'eth1'所使用的网口,eth1即代表第二个网口
    option proto 'static' 静态IP
    option ipaddr '11.0.0.1' 随便设置(不与其他设备冲突即可)
    option netmask '255.255.255.0' 子网掩码
    option ip6assign '60' 内网IPV6

config interface 'wan' WAN口配置
    option ifname 'eth0' WAN口配置,使用第一个网口
    option proto 'static' 静态IP
    option ipaddr '10.0.0.100' 不与其他设备冲突即可
    option netmask '255.255.255.0' 子网掩码
    option gateway '10.0.0.1' 网关

config interface 'wan6'WAN口ipv6配置
    option ifname 'eth0'使用第一个网口
    option proto 'dhcpv6'自动获取IPV6地址

然后我们按 ESC 键退出编辑,输入:wq保存编辑

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

完成后输入 reboot 回车重启LEDE系统

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

三、开始使用LEDE软路由系统

我们把群晖上第二个网口与我们的电脑相连,访问后台管理(例如我这里:10.0.0.100或者是11.0.0.1都可以)默认密码为koolshare

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

这样就登陆到了LEDE的管理后台

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

先来更新一下软件中心

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

可以在线安装插件,不过没有XX上网插件,需要离线安装

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

我们选择“离线安装”,选择插件压缩包,点击“上传并安装”

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

安装完成。

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

当然,如果你需要拨号上网的话,就在接口这里将WAN口协议改为PPPoE

《黑群晖一机多用!利用VMM虚拟机套件安装LEDE软路由系统》

其他功能大家就自行研究摸索吧,这里就不再赘述。有问题欢迎加群讨论或在文章下方留言。

下载地址

Koolshare定制LEDE系统官方下载:http://firmware.koolshare.cn/LEDE_X64_fw867/

XX上网离线插件官方下载:https://github.com/hq450/fancyss_history_package/tree/master/fancyss_hnd

包含Koolshare定制LEDE系统与XX上网插件,均为文章发布时最新版。

Tips:资源收集于互联网,不保证完全可用。破解资源仅供学习参考,请于下载后24小时内删除!如侵犯到您的合法权益,请速联系本站删除侵权资源!请在下载前阅读本站《免责声明》!如您遇到资源链接失效,请您通过评论或留言的方式联系网站管理员!
点赞

发表评论